White noise from Artist 15

Discussion - Artist Series amplifiers. The New Classic.
Post Reply
Mike
Posts: 3
Joined: Wed Mar 07, 2018 11:57 pm

Thu Mar 08, 2018 12:05 am

Hello all,

I just purchased a brand new Artist 15 and while I like the tones of the amp, it makes an audible hiss or white noise sound reminiscent of what a high gain amplifier would sound like with the gain knob cranked up. This is odd to me given the fact that it is such a low gain amplifier. The white noise is the same regardless of the channel, cables, etc. At lower volumes, you can hear the white noise even when playing. I just find it very odd that such a low gain amplifier would make this kind of white noise. Does anyone with the Artist 15 amp experience this same sound?

Mike
Posts: 3
Joined: Wed Mar 07, 2018 11:57 pm

Wed Mar 21, 2018 6:20 pm

Just as an FYI for anyone thinking about purchasing this amp. The Artist 15 makes a ton of white noise, so beware if that bothers you. I was thinking it was just my amp with a bad tube or something, but since I had purchased mine from Sweetwater, one of their Techs pulled another amp to see if it made the same noise. He called me back a couple of days later after he was able to test and told me that he now understands what I mean. So, unfortunately it was not just my amp and I have returned it.

I think Blackstar was close with with this with this amp as the actual sounds are pretty good, but the white noise is ridiculously loud and is very annoying, you can seriously hear it when you're playing. I'm not sure if it's cheap components, the ISF (which by the way, putting it to the "USA" side just makes the amp sound terrible IMO), or what but at bedroom levels the white noise is annoying, cranking the amp up the white noise gets loud. I couldn't imagine having this thing mic'd up live as it sounds like it has a distortion pedal in front of it with the all the knobs dimed out and that is weird for such a low gain amplifier. Not quite understanding how Blackstar could be okay with that.

I also find channel one pretty much unusable as it is very difficult to dial in a good sound with just the tone knob. But, I used channel two and got it dialed in and with a Wampler Paisley Deluxe in front of it, sounds awesome. So, again Blackstar was close, but IMO not close enough and I'll wait and see if I can get my hands on a Marshall Origin.

grayprog
Posts: 3
Joined: Fri Jul 06, 2018 4:45 pm

Fri Jul 06, 2018 4:55 pm

So, all of them have this noise? No YouTube review or other online reviews mention this. I just received my Artist 15 yesterday and also have the hiss. What other amps are comparable to Artist 15 but don't have this problem (and I would love one a bit lighter/smaller as well). I was researching for a new amp for a very long time, an amp to go with my pedalboard, so this is quite unfortunate.

fordj36
Posts: 1
Joined: Sat Sep 08, 2018 7:11 am
Location: https://4wdlife.com/

Tue Sep 11, 2018 12:44 pm

I’ve a problem with Blackstar Artisan 15 amp, morning after gig last Saturday it’s just stop work in 5w triode mode at all (just a fart sound) but still sound good on pentode 15w on all channels.

gregorl
Posts: 2
Joined: Tue Aug 23, 2016 12:37 pm

Wed Sep 12, 2018 6:52 am

Mine is very quiet and I did see a comment in one of the reviews remarking how quiet they are, so if yours has noise maybe you need to get it checked out. Of course if you're diming the gain then theres going to be some noise. If you really want to hear noise crank the gain on a tumnus deluxe....That apparently has something to do with the charge pump design on klon style pedals....

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest