FS-12 footswitch not working on ID:CORE 100

General Discussion Forum - Voice The Sound In Your Head
Post Reply
Pence169
Posts: 3
Joined: Tue Sep 10, 2019 10:07 pm

Wed Sep 11, 2019 1:30 pm

Hi there folks,

I just bought an ID:CORE 100 amp alongside with the FS-12 but it doesn't seem to work together.
When I connect the footswitch there is a high pitch noise coming from the footswitch for about 2 seconds, and then the amp seems to recognize it by flashing all the bank+channels lights (as it does with the FS-13).

I've managed to get it to work just once yesterday. I suspect that there's some loose component inside the footswitch causing a malfunction, but I'm worried about compatibility as well after reading a lot of issues from ID:COREs. That's frustrating because both amp and FS-12 are brand new :oops:

What are your thoughts? Thanks in advance.

User avatar
fender62
Posts: 15
Joined: Fri Mar 01, 2019 7:22 pm
Location: wales u.k

Wed Sep 11, 2019 7:01 pm

i have an id core 150, and the fs-12, works perfectly for me, no high pitch noise from mine, are you sure its actually coming from the footswitch, have you tried a different cable, you have got in connected to amp out on the footswitch, you could try resetting your amp, with all cables connected, if none of that works, you could get a refund on footswitch or replacement, if its under guarantee anymore, you could take it apart and look for loose connections dry solder joints etc
resolder dry joints easy.

Pence169
Posts: 3
Joined: Tue Sep 10, 2019 10:07 pm

Thu Sep 12, 2019 4:11 pm

fender62 wrote:
Wed Sep 11, 2019 7:01 pm
i have an id core 150, and the fs-12, works perfectly for me, no high pitch noise from mine, are you sure its actually coming from the footswitch, have you tried a different cable, you have got in connected to amp out on the footswitch, you could try resetting your amp, with all cables connected, if none of that works, you could get a refund on footswitch or replacement, if its under guarantee anymore, you could take it apart and look for loose connections dry solder joints etc
resolder dry joints easy.
Thanks for the feedback. I tried with a different cable as well without success. I went to the store and asked the salesman if they could test in another ID:CORE amp to ensure that isn't an issue related with my amp. Well, it did not work at all and I returned it and got refunded.
Now I'll try to find another FS-12 unit online. That's frustrating :(

User avatar
fender62
Posts: 15
Joined: Fri Mar 01, 2019 7:22 pm
Location: wales u.k

Thu Sep 12, 2019 11:15 pm

well at least you know you have a faulty unit, mine works perfectly, id would try one out at a shop, to make sure it works before you purchase it.
saves you the bother of sending it back etc.

Pence169
Posts: 3
Joined: Tue Sep 10, 2019 10:07 pm

Fri Sep 13, 2019 6:19 pm

I'll try it... thanks.

BTW, is FS-12 the only one compatible with IDCORE 100/150? I was wondering if the FS-10 is compatible as well.

User avatar
fender62
Posts: 15
Joined: Fri Mar 01, 2019 7:22 pm
Location: wales u.k

Fri Sep 13, 2019 6:25 pm

it's not compatible, i made the mistake and bought one used, i even asked blackstar about it...answer no.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 9 guests