Emulated out on I'd core 20

Discussion - ID:Core amplifiers.
User avatar
Sonofarich
Posts: 605
Joined: Thu Feb 24, 2011 1:00 am

Wed Feb 08, 2017 11:04 pm

Jimdurkin wrote:terminology might have been a bit strong but so what ? its just my choice of terminology, multiple emails back and forth to blackstar resolved nothing.
got told to check using correct cables and to take amp back to shop, even though I had explained in emails that i had done this already, best they could come up with was a ground loop !! couldn`t even tell me the output impedance for the emulated out. I knew this was the issue ( an impedance mismatch ) but they wished me luck but could not help.....
yes I was frustrated as it happens. overreacting ? other than my terminology being not to your liking, I don`t see where in the post am I overreacting.
I get it and empathize...just putting it into perspective. Bad service...yes. Incompetent...yes. Total BS...yes. Criminal...no.

That's the overreacting part...don't kill the messenger and not my terminology (i.e. no crime committed). :D

crim·i·nal (ˈkrim(ə)n(ə)l) - adjective

- relating to crime.

miket
Posts: 29
Joined: Sat Aug 20, 2016 9:55 am

Fri Feb 10, 2017 12:45 am

Jimdurkin wrote:Thank you Mikel your advice about The Di led me the right way.
Cool!! thanks for the update! I've had to use it on a few PA boards when running stereo from EM out. On some boards it was fine.. others buzz, hum or didn't work. Worked every time with the DI. Not a fault of Blackstar either.. just how some things go. That's why they make these DI's, hum eliminators and so on.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 0 guests