HT20 No sound

General Discussion Forum - Voice The Sound In Your Head
Post Reply
DenisW
Posts: 14
Joined: Sun May 30, 2010 12:00 am
Location: East Sussex UK

Sat Oct 23, 2010 4:49 pm

Hi all, I hope you can help, I have an HT20 Combo only a few months old. I used it three days ago and everything was fine. Turned it on today but couldn't get any sound!! Anyone have any ideas as to what the problem could be? I've tried turning all volume knobs, Clean with Master Overdrive Vol with master volume but still can't get a peep out of it. I've checked cable to guitar and that works fine with my little marshal amp so it's not that . the power light comes on but no sound. Any help would be much appreciated.

DenisW

Ettery
Posts: 51
Joined: Thu May 20, 2010 12:00 am

Sat Oct 23, 2010 7:54 pm

DenisW wrote:Hi all, I hope you can help, I have an HT20 Combo only a few months old. I used it three days ago and everything was fine. Turned it on today but couldn't get any sound!! Anyone have any ideas as to what the problem could be? I've tried turning all volume knobs, Clean with Master Overdrive Vol with master volume but still can't get a peep out of it. I've checked cable to guitar and that works fine with my little marshal amp so it's not that . the power light comes on but no sound. Any help would be much appreciated.

DenisW
I had a similar problem with mine..
Speak to Blackstar about it and see if they can fix it for you.

DenisW
Posts: 14
Joined: Sun May 30, 2010 12:00 am
Location: East Sussex UK

Sun Oct 24, 2010 9:30 am

Hi Ettery, Thanks for your reply. I have since established that the Overdrive volume works ok plenty of amplification. It appears that it is the Clean volume that's giving no sound. Did your Overdrive work?

Vit
Posts: 1
Joined: Sun Jun 05, 2011 12:00 am

Sun Jun 05, 2011 8:10 pm

Hi, I have similar problem with my HT20 head. OD channel is working fine but Clean stopped working. It was OK 2 days ago but today it just won't work. Please advise, thanks.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 24 guests