Why I have come to regret buying my ID 60

Discussion - ID:Series amplifiers.
Post Reply
tommytiptree
Posts: 26
Joined: Tue Apr 01, 2014 10:20 am

Tue Sep 22, 2015 11:33 am

Hi, After owning my ID 60 for over a year I have now come to regret buying it. Don't get me wrong here, the sounds on this amp are fantastic, the effects are really top notch, a great sounding amp. What then is the problem?.
Simply this, I purchased this amp so that I could do away with my effect pedals and simplify my setup with the ID footswitch and a volume pedal in the effects loop. Not too much too ask. However, plugging anything into the effects loop results in a lot of noise. Does not matter if it is a volume pedal, multi FX, or a single pedal, it all results in excess noise......
I do not want my volume pedal in front of the amp as this affects the distortion. I like to run it in the effects loop, a simple requirement.
I do not think it is acceptable to be told that the effects loop is not really a loop but is emulated therefore it will not work as good as a "real" effects loop.
So where does that leave me. Back to square one, running my TC electonics multi fx in front of the amp with the volume pedal between it and the amp.
A great shame as this one defect ruins what should be a great all in one amp. Wish I had investigated Line 6 amps or another manufacturer.

User avatar
flimbo
Posts: 205
Joined: Sun Apr 13, 2014 2:53 pm

Tue Sep 22, 2015 11:39 am

Have you tried updating the firmware to see if it helps?
http://www.blackstarinsider.co.uk/
Or previous firmware here...
http://www.blackstarinsider.co.uk/previous-releases.php

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 5 guests