Emulated out on I'd core 20

Discussion - ID:Core amplifiers.
Jimdurkin
Posts: 10
Joined: Sat Jan 21, 2017 5:21 pm

Sat Jan 21, 2017 5:41 pm

Hi. I have just bought an Id core 20. I have connected a stereo mini jack to the core which is split into 2 1/4 inch mono jacks panned left and right in the 8 track we use. A korg D888 just get a high pitched whistle sound.the korg has TRS 1/4 inch inputs. The 2 1/4 inch jacks I use are TS type. Would this be the reason for this ! Took the core and leads back to the store where it worked fine. Any tips would be greatly appreciated.

miket
Posts: 29
Joined: Sat Aug 20, 2016 9:55 am

Sun Jan 22, 2017 3:16 am

Are you using the em output jack?

Check that phantom power is not active on the ch inputs.

Jimdurkin
Posts: 10
Joined: Sat Jan 21, 2017 5:21 pm

Sun Jan 22, 2017 5:01 pm

Yes, using emulated out as per manual. Phantom power not on. I believe the inputs on korg are mic/line trs, the 2 mono jacks are ts. Could this be the problem ?. My understanding is trs are balanced inputs ? And the ts mono jacks are unbalanced ?

Jimdurkin
Posts: 10
Joined: Sat Jan 21, 2017 5:21 pm

Mon Jan 23, 2017 9:03 pm

The manual for the I'd core 20 v2 says the emulated output is a 1/8 stereo minijack to a split lead left and right 1/4 inch mono. Can anyone tell me what the output impedance is on each of the left and right mono Jacks. I am trying to find out the input impedance of the korg D888 and hopefully get a Di box to match the impedance. Only. Other thing I can think of is,the Korg has TRS inputs, the 2 mono leads would be TS. Can anyone see where
I am going with this and help me towards the right path. I have had email conversations with Blackstar and sorry to say but they can't help me. I am reluctant to get my money back on this because the sound is sublime on the clean warm alone. Worth the money just for that. If only I could record the thing and sorry USB and a daw is not an option for me.

Jimdurkin
Posts: 10
Joined: Sat Jan 21, 2017 5:21 pm

Wed Jan 25, 2017 1:08 pm

no takers, any one from Blackstar interested in helping ?

miket
Posts: 29
Joined: Sat Aug 20, 2016 9:55 am

Thu Jan 26, 2017 2:21 pm

Jimdurkin wrote:The manual for the I'd core 20 v2 says the emulated output is a 1/8 stereo minijack to a split lead left and right 1/4 inch mono. Can anyone tell me what the output impedance is on each of the left and right mono Jacks. I am trying to find out the input impedance of the korg D888 and hopefully get a Di box to match the impedance. Only. Other thing I can think of is,the Korg has TRS inputs, the 2 mono leads would be TS. Can anyone see where
I am going with this and help me towards the right path. I have had email conversations with Blackstar and sorry to say but they can't help me. I am reluctant to get my money back on this because the sound is sublime on the clean warm alone. Worth the money just for that. If only I could record the thing and sorry USB and a daw is not an option for me.
Hmm I'm not sure it has anything to do with impedance or not. What happens when you plug the mono jacks half way in the Korg inputs? Usually a TRS input won't give an issue with that, but a DI you can try and what I have used on my EM Out for XR18 mixer and recorder at gigs is this:

http://www.musiciansfriend.com/pro-audi ... adType^PLA

I also tried the EM out of the amps to a Zoom MRS1024 recorder. It's fine too. Stereo mini jack to dual mono jacks. Same thing. Can you post a video clip on Youtube so we can see what is going on and listen to the noise you have?

Jimdurkin
Posts: 10
Joined: Sat Jan 21, 2017 5:21 pm

Sat Feb 04, 2017 8:51 pm

Sorted. £15 gak Di box. This being the official blackstar forum I would have thought help from blackstar would have been forthcoming. Emailing them was a complete waste of time. Seems to be a criminal lack of knowledge within blackstar about their own products.

User avatar
Sonofarich
Posts: 607
Joined: Thu Feb 24, 2011 1:00 am

Sun Feb 05, 2017 8:15 pm

Criminal?? I think you're frustrated and overreacting a little.

Jimdurkin
Posts: 10
Joined: Sat Jan 21, 2017 5:21 pm

Tue Feb 07, 2017 1:24 pm

terminology might have been a bit strong but so what ? its just my choice of terminology, multiple emails back and forth to blackstar resolved nothing.
got told to check using correct cables and to take amp back to shop, even though I had explained in emails that i had done this already, best they could come up with was a ground loop !! couldn`t even tell me the output impedance for the emulated out. I knew this was the issue ( an impedance mismatch ) but they wished me luck but could not help.....
yes I was frustrated as it happens. overreacting ? other than my terminology being not to your liking, I don`t see where in the post am I overreacting.

Jimdurkin
Posts: 10
Joined: Sat Jan 21, 2017 5:21 pm

Tue Feb 07, 2017 8:00 pm

Thank you Mikel your advice about The Di led me the right way.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 2 guests