HT-Dual - a real disappointment

Discussion - HT Pedals. Heavenly Boxes.
Post Reply
bobber
Posts: 2
Joined: Mon Sep 08, 2014 4:37 pm
Location: Swansea

Wed Oct 29, 2014 10:02 am

I'm really really gutted by the relability of these pedals. I've already had two of these - and both developed a fault. The first one, bought 2nd hand (a 3yo pedal), broke down after just a couple of months after purchase - check my other post for details. Took it for repair that cost me £70, and it broke down again after just a week of use. The tech (authorized service) said he contacted Blackstar Tech dept, but even together they had dificulty to track down the cause. Broke down once more in front of the service guy, when I came to collect it. It cost me an extra £20 when I finally got it back. So the overall cost of the pedal and repairs came round to be more then a new one.

After a while I thought I'd give it a second chance, as the sound - even through the emulated out - is just brilliant. So I went for a new one this time, thinking that the warranty will save me from expensive repairs. Imagine my disappointment, when I plugged in the new pedal and it turned out to be faulty! This time round, for about 10 seconds after plugging the pedal into the wall socket the LED diode lighting up die valve flashes and none of the footswitches work, then after that few seconds it seems to come back to life. Phoned Blackstar and was told that it is apparently a known issue with this pedals.

So all in all, beware what you may experience before buying that pedal.

Toktu
Posts: 4
Joined: Mon Sep 08, 2014 3:44 pm
Location: Costa Rica

Tue Nov 04, 2014 10:58 pm

Do you mean something like this?


LED flashes in HT Dual
Postby Toktu » Fri Sep 19, 2014 7:49 am

Hi everyone!

I recently bought an HT Dual, and have noticed that after a few minutes working, like 20 minutes or more, if I take it off from the power supply and then plug it again, the LEDs flashes like 6 times or more, like if it was "warming", but it is already warm, and don't know if it is normal.

I know that it flashes when you turn it on, but don't know if it's normal that do this more than one time.

Maybe it's a dumb question, but I'm new with the HT Dual, and I'll be very thankful with your answers.
Toktu

Posts: 3
Joined: Mon Sep 08, 2014 7:44 am
Location: Costa Rica

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 3 guests