HT Club 40 Combo weird behaviour

Discussion - HT Venue amplifiers. Inspiration from Studio to Stage.
Post Reply
klevieter
Posts: 2
Joined: Tue Nov 03, 2015 7:47 pm

Tue Nov 03, 2015 9:07 pm

Hi,
Maybe some of you can help me. I own a Blackstar HT Club 40W combo tube amplifier. Since a couple of days, a couple of minutes after turning it on, it makes a popping sound and then the volume turns very low all of a sudden. When I turn it off, wait an hour or so before turning it on again, the volume level is normal and the same thing happens.

Now I haven't got the faintest idea of what is going wrong here since I know very little of amps. I did, however, take a look at the tubes to see if I can spot some abnormality there, but I don't really know how they're supposed to look.

So... what can be wrong/should I do. I can post pictures on request ofcourse.
thanks!

User avatar
thephantum
Posts: 1160
Joined: Wed Jan 29, 2014 7:42 pm
Location: Virginia, United States

Tue Nov 03, 2015 9:36 pm

It sounds like a bad power tube. Do not continue to turn it on. You will do more damage. How old is the amp?

klevieter
Posts: 2
Joined: Tue Nov 03, 2015 7:47 pm

Wed Nov 04, 2015 7:41 am

only four years

User avatar
JohnBNY
Posts: 208
Joined: Sun Sep 29, 2013 1:14 pm
Location: Bedford, New York

Wed Nov 04, 2015 10:50 am

If you have the original tubes in the amp, it's about time for a change and bias.

User avatar
thephantum
Posts: 1160
Joined: Wed Jan 29, 2014 7:42 pm
Location: Virginia, United States

Wed Nov 04, 2015 2:42 pm

Yea. Unless you rarely use it and only at low volume, four years is a long time for tubes in a guitar amp. Find an amp tech, have it retubed and checked out.

poisondrop
Posts: 16
Joined: Mon Aug 17, 2015 5:24 am

Wed Dec 30, 2015 2:46 am

i had a similar problem like this one. I thought it was a bad effects loop and tubes but turns out i was using a faulty voltage regulator. After i stopped using the voltage regulator ( i now plug my amp on a surge proof outlet ) the problem disappeared. no popping sounds, no volume change, everything works perfect, and the amp sounds eargasmicly better than ever.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 9 guests