worrying noises.. (HT-20)

Discussion - HT Venue amplifiers. Inspiration from Studio to Stage.
Post Reply
Ettery
Posts: 51
Joined: Thu May 20, 2010 12:00 am

Sat Aug 21, 2010 4:53 pm

well.. i was just playing my guitar and literally out of no where i get this high pitched screeching noise coming from my amp.. it's happened twice today and early it sounded like something pop in the amp, and there was no sound coming out of it and i played, and then the amp popped again and i coulld playu through it. The screech's tend to happen whenever i turn my amp on, and its scary as hell :shock:
Last edited by Ettery on Sun Aug 22, 2010 12:05 pm, edited 1 time in total.

snakestretcher52
Posts: 15
Joined: Mon Jul 05, 2010 12:00 am
Location: Exeter UK

Sun Aug 22, 2010 11:34 am

Which model is it?

Ettery
Posts: 51
Joined: Thu May 20, 2010 12:00 am

Sun Aug 22, 2010 11:48 am

oh haha, sorry about that.. HT-20.

snakestretcher52
Posts: 15
Joined: Mon Jul 05, 2010 12:00 am
Location: Exeter UK

Sun Aug 22, 2010 12:30 pm

I had a horrible suspicion it was! Swap all the valves out. It seems Blackstar are using shite components judging by all the HT-20 problem posts.

Ettery
Posts: 51
Joined: Thu May 20, 2010 12:00 am

Sun Aug 22, 2010 12:32 pm

snakestretcher52 wrote:I had a horrible suspicion it was! Swap all the valves out. It seems Blackstar are using shite components judging by all the HT-20 problem posts.
I think i might, i'll try see if i can take it down to the music shop tomorrow or tuesday :)

ozzyjim
Posts: 13
Joined: Fri Aug 20, 2010 12:00 am

Sun Aug 22, 2010 1:09 pm

Keep us informed Exeter, interested to know any results.

Cheers
Jim

Ettery
Posts: 51
Joined: Thu May 20, 2010 12:00 am

Sun Aug 22, 2010 3:16 pm

if it helps, i recorded the noise it makes via my phone.. it doesnt happen till around 30 seconds and the playing starts at around 24 seconds, since the amp had to warm up and that. (dont mind the playing.. first thing that came to my head)
here's the file;
http://www.megaupload.com/?d=II4E7H8L
dont listen to this too loud..
oh and dont worry, its only 312kb :)

gt_jumper
Posts: 320
Joined: Sun Apr 11, 2010 12:00 am
Location: Queensland Australia

Sun Aug 22, 2010 6:01 pm

Holy crap that scared the shit outta me........

Most probably the power valves dude.

Ettery
Posts: 51
Joined: Thu May 20, 2010 12:00 am

Sun Aug 22, 2010 6:09 pm

I have to go through that everytime i turn it on! :(
Hopefully i'll get it seen to soon.. my friends Dad might be able to fix it. I dont really wanna pay loads at a music shop =/

gt_jumper
Posts: 320
Joined: Sun Apr 11, 2010 12:00 am
Location: Queensland Australia

Sun Aug 22, 2010 7:16 pm

Mine cost $100au for new valves and techy to bias them in. Its alot but knowing your amps going to sound great after the switch is flicked is worth every cent.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 9 guests