ID:CORE 20 no sound

General Discussion Forum - Voice The Sound In Your Head
Post Reply
ricwest29
Posts: 3
Joined: Wed Jan 04, 2017 12:50 am
Location: Los Angeles

Wed Jan 04, 2017 12:56 am

I just unboxed my new Blackstar ID:Core 20 practice amp and there is no output audio. I tried tow different guitars and I even reset it to factory, yet guitar plugged in, power on, volume up, and nothing.

Has anybody had this issue? Perhaps I've done something wrong? Any assistance is appreciated.

Ricwest

ricwest29
Posts: 3
Joined: Wed Jan 04, 2017 12:50 am
Location: Los Angeles

Wed Jan 04, 2017 2:12 am

OK am I crazy? I went back to the amp to pack it up to return, but first I cranked up volume and gain and I started to hear sound. This is great! I thought until I tried the presets. Clean Warm is very low output, as is clean warm. Crunch 1 and Crunch 2 OK, little more volume too, but OD 1 and OD 2 ? nothing, it made a sound on OD 1 for a split second then stopped working.

So the amp seems to work, very low volume, and no OD1 and OD 2. I want to return it for a replacement, but if this is the way this performs, I may not want it back. My FLY 3 is louder at 3 watts.

Any suggestions?

Ricwest

edwberger
Posts: 14
Joined: Fri Aug 28, 2015 3:38 am

Sat Jan 07, 2017 9:29 pm

I'd try another cable as well, but that sounds like a defective amp to me.

ricwest29
Posts: 3
Joined: Wed Jan 04, 2017 12:50 am
Location: Los Angeles

Tue Jan 10, 2017 1:06 am

OK, I returned the AMP and they shipped me a new one. Side by side, two guitars two cables, again no sound. So I did a reset, still silent. I have one more idea and then I may have to return it and buy an Orange or a Marshall.

Sammosas
Posts: 3
Joined: Tue Jan 03, 2017 12:51 am

Mon Jan 16, 2017 2:37 pm

There's a sound gate on the OD1 and OD2 channels. I noticed my ID CORE10 was silent unless played moderately loud with the default sound gate setting on. You'd need to use the insider software to modify this.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 19 guests