Search found 51 matches

by Ettery
Sat Nov 06, 2010 3:55 pm
Forum: HT Venue Series
Topic: HT-100 Sound Issue (Powering on the Amp)
Replies: 5
Views: 5491

Re: HT-100 Sound Issue (Powering on the Amp)

Had the exact same problem with my HT-20. It was the Power Valves i think, try and see if Blackstar can fix it for you.
by Ettery
Tue Nov 02, 2010 9:39 pm
Forum: Blackstar Video Thread
Topic: Our first proper vid!
Replies: 3
Views: 6781

Re: Our first proper vid!

Really quite like this song, you should get a vid posted on youtube.
by Ettery
Sat Oct 23, 2010 7:54 pm
Forum: Blackstar Amps
Topic: HT20 No sound
Replies: 3
Views: 5497

Re: HT20 No sound

Hi all, I hope you can help, I have an HT20 Combo only a few months old. I used it three days ago and everything was fine. Turned it on today but couldn't get any sound!! Anyone have any ideas as to what the problem could be? I've tried turning all volume knobs, Clean with Master Overdrive Vol with...
by Ettery
Wed Oct 06, 2010 4:25 pm
Forum: HT Venue Series
Topic: Ht stage 60 valve blown after 30 hours of playing
Replies: 10
Views: 8957

Re: Ht stage 60 valve blown after 30 hours of playing

Was that 30 hours straight? :shock:
by Ettery
Sat Oct 02, 2010 10:46 pm
Forum: HT Venue Series
Topic: idiot !!!!!!
Replies: 2
Views: 4235

Re: idiot !!!!!!

It all depends on your needs and that, but if i had the choice i'd get a series one.
by Ettery
Thu Sep 02, 2010 3:19 pm
Forum: Blackstar Video Thread
Topic: New HT 1 in video !
Replies: 3
Views: 8056

Re: New HT 1 in video !

This has been posted elsewhere, and once again you're advertising your other forum..
by Ettery
Sat Aug 28, 2010 12:53 am
Forum: Blackstar Amps
Topic: Blackstar HT-1 1 watt mini amp
Replies: 18
Views: 27408

Re: Blackstar HT-1 1 watt mini amp

Looks awesome :)
by Ettery
Thu Aug 26, 2010 11:26 pm
Forum: Series One
Topic: S1 Cab question.
Replies: 7
Views: 9190

Re: S1 Cab question.

Hi, i appreciate your honesty and please dont get offended, all i meant from my question is that the S1 cab is like SUPER AWESOME and i personally believe that the MG100HDFX is not a good amp....had it Now the JVM 410H.....i would kill a man for that :twisted: rock on bro....... http://sphotos.ak.f...
by Ettery
Sun Aug 22, 2010 6:09 pm
Forum: HT Venue Series
Topic: worrying noises.. (HT-20)
Replies: 9
Views: 8507

Re: worrying noises.. (HT-20)

I have to go through that everytime i turn it on! :(
Hopefully i'll get it seen to soon.. my friends Dad might be able to fix it. I dont really wanna pay loads at a music shop =/
by Ettery
Sun Aug 22, 2010 3:20 pm
Forum: Show us your Blackstar set-up
Topic: Post your Blackstar amp!
Replies: 203
Views: 273914

Re: Post your Blackstar amp!

Image

latest edition.. a road worn 60s strat :)