Search found 10 matches

by jamminfool77
Sat Dec 04, 2010 10:39 pm
Forum: HT Venue Series
Topic: New Blackstar HT-40 problem?
Replies: 14
Views: 17184

Re: New Blackstar HT-40 problem?

Hi all, I just got my new HT-40 couple of days ago and everything seems to work fine but I've notice something I didn't expect at all: - When switching channels -either using the footswitch or the switch in the amp- the change is not immediate, there is some latency, I couldn't measure it but it's ...
by jamminfool77
Sat Nov 13, 2010 5:38 pm
Forum: HT Venue Series
Topic: HT-100: Switching Channels Sound Issues (Clean to OD2)
Replies: 14
Views: 10116

Re: HT-100: Switching Channels Sound Issues (Clean to OD2)

The only thing i can think of is that the foot switch port on the amp head is a serial port like your printer. The techs probably get an update via internet or sent to them on Cd, plug it into the serial port, and then initiate the firmware update. Maybe if you contact the BlackStar boy s in the UK ...
by jamminfool77
Sat Nov 13, 2010 5:37 pm
Forum: HT Venue Series
Topic: HT-100 - Ver 2.0 Firmware update
Replies: 6
Views: 5972

Re: HT-100 - Ver 2.0 Firmware update

thats sounds like complete BS there is no DSP in these amps that I am aware of .... except perhaps the reverb http://illiweb.com/fa/i/smiles/icon_scratch.png The only thing i can think of is that the foot switch port on the amp head is a serial port like your printer. The techs probably get an upda...
by jamminfool77
Sat Nov 13, 2010 5:36 pm
Forum: HT Venue Series
Topic: HT-100 Sound Issue (Powering on the Amp)
Replies: 5
Views: 5418

Re: HT-100 Sound Issue (Powering on the Amp)

Seeing your experience I will not send my ht-100 to Blackstar for de switching channel issue... I will live with it.... good luck. There is no reason you should live with a scrwed up amp you paid hundreds for. Hopefully it's under warranty and cool guitar shops will typically give you a loaner amp....
by jamminfool77
Thu Nov 11, 2010 1:41 am
Forum: HT Venue Series
Topic: HT-100 Sound Issue (Powering on the Amp)
Replies: 5
Views: 5418

Re: HT-100 Sound Issue (Powering on the Amp)

hi,try spraying the pins on your tubes with some electrical spray and plug them in and out a few times,they may not be making good contact,it has worked for me a few times on marshall and fender amp's i had years ago. I tried cleaning the pins on all the tubes with component cleaner and compressed ...
by jamminfool77
Fri Nov 05, 2010 8:33 pm
Forum: HT Venue Series
Topic: HT-100 Sound Issue (Powering on the Amp)
Replies: 5
Views: 5418

HT-100 Sound Issue (Powering on the Amp)

One thing after the next with my new HT-100. My new problem is every time i turn on the amp, and the tubes start to warm up, this nasty sound comes through my speakers. It sounds like if you stuck the guitar cord on something metal, but, amplify that buzz sound by 20x. It doesn't matter if the volu...
by jamminfool77
Wed Oct 27, 2010 8:33 pm
Forum: HT Venue Series
Topic: HT-100: Switching Channels Sound Issues (Clean to OD2)
Replies: 14
Views: 10116

Re: HT-100: Switching Channels Sound Issues (Clean to OD2)

Blackstar support has been very good so far. They reposnded to my email and this issue. Here is their response - Hi there, Thanks for the enquiry. The Firmware update is a software update that reprograms the switches in your footswitch. There will be no other updates to the amp. Hope this helps. Kin...
by jamminfool77
Wed Oct 27, 2010 8:32 pm
Forum: HT Venue Series
Topic: HT-100 - Ver 2.0 Firmware update
Replies: 6
Views: 5972

Re: HT-100 - Ver 2.0 Firmware update

Blackstar support has been very good so far. They reposnded to my email and this issue. Here is their response - Hi there, Thanks for the enquiry. The Firmware update is a software update that reprograms the switches in your footswitch. There will be no other updates to the amp. Hope this helps. Kin...
by jamminfool77
Fri Oct 22, 2010 11:20 pm
Forum: HT Venue Series
Topic: HT-100 - Ver 2.0 Firmware update
Replies: 6
Views: 5972

HT-100 - Ver 2.0 Firmware update

I recently got my HT-100 repaired. They said it needed the firmware ver 2.0 update. However, what that is they don't know. What exactly does this firmware update provide? What does it do?

If anyone knows please educate me. Thank you.
by jamminfool77
Mon Sep 13, 2010 7:06 pm
Forum: HT Venue Series
Topic: HT-100: Switching Channels Sound Issues (Clean to OD2)
Replies: 14
Views: 10116

HT-100: Switching Channels Sound Issues (Clean to OD2)

I recently purchased a HT-100 and i absolutely love the sound, what a great amp. However, when i switch from the clean channel to OD2 the OD2 channel is muffled and the volume is slightly lower. Almost like the OD2 channel loses it's brightness and punch. This only happens when going from clean to O...