Search found 11 matches

by lucknow1856
Thu Jul 28, 2011 3:44 pm
Forum: Artisan Series
Topic: Need Advice with distortion pedals on Artisan 30 combo
Replies: 6
Views: 8674

Re: Need Advice with distortion pedals on Artisan 30 combo

I suspect this is not an easy question to answer for many people if, like me, they use the Artisan in pub/club size venues where it's not really an option to push the amp flat out - it's very loud for a 30 watt amp. I use the Blackstar Drive pedal to dirty things up (for solos, riffs etc) as the amp...
by lucknow1856
Mon Oct 04, 2010 7:34 pm
Forum: Artisan Series
Topic: Is my Artisan 30 lacking gain??...
Replies: 2
Views: 5142

Re: Is my Artisan 30 lacking gain??...

Hello all, I recently acquire a lovely Artisan 30 combo, and I'm totally in love with it's tone and looks. But I have one issue, the second channel doesn't provide quite as much gain as I'd like... and I'm certainly not a high gain, metal kinda guy... I'm just looking to get that 70's rock tone tha...
by lucknow1856
Wed Aug 11, 2010 9:56 pm
Forum: Show us your Blackstar set-up
Topic: The Pedalboard thread
Replies: 56
Views: 61520

Re: The Pedalboard thread

Thanks. Yes, I have a good mix of tones there for my Artisan 30. Gives me a good spread of what I need. I have 3 different overdrive/distortion settings with the Providence/OCD/Dual and I use the green channel on the Dual as clean boost rather than crunch. The Providence is an amazing pedal - I use...
by lucknow1856
Wed Aug 11, 2010 5:23 pm
Forum: Show us your Blackstar set-up
Topic: The Pedalboard thread
Replies: 56
Views: 61520

Re: The Pedalboard thread

Here's my current board http://i403.photobucket.com/albums/pp119/ToonLP/Axe/_Y3X7575.jpg Some nice drive/distortion items on there Toon - you certainly seem to have all bases covered in those terms. It would be interesting to know the sounds you use the Providence Stampede and the Fulltone OCD for ...
by lucknow1856
Fri Jul 09, 2010 6:00 pm
Forum: Artisan Series
Topic: Has anyone else had any problems with their Artisan 30?
Replies: 9
Views: 10771

Re: Has anyone else had any problems with their Artisan 30?

Glad to hear they're replacing it, though you did seem to have a cast-iron case after all those probs.
by lucknow1856
Wed Jul 07, 2010 4:21 pm
Forum: Blackstar Amps
Topic: Amp Covers!
Replies: 26
Views: 21018

Re: Amp Covers!

yeah i got a cover from Silverstone for my Artisan 30 - fits like a glove. How long did it take to get yours after ordering? It was nearly 3 weeks or thereabouts. Actually I did send a follow-up email after about 14 days - they replied promptly and said the delay was waiting for the material for th...
by lucknow1856
Wed Jul 07, 2010 3:41 pm
Forum: Artisan Series
Topic: Has anyone else had any problems with their Artisan 30?
Replies: 9
Views: 10771

Re: Has anyone else had any problems with their Artisan 30?

I'm not very techie so won't be much help on that score (sorry) but if it helps this doesn't happen on mine. With all levels at zero you should hear nothing. I certainly wouldn't accept that problem - if the amp has been sold to you like that and it's been like that with normal use from day one then...
by lucknow1856
Wed Jul 07, 2010 3:08 pm
Forum: Blackstar Amps
Topic: Amp Covers!
Replies: 26
Views: 21018

Re: Amp Covers!

yeah i got a cover from Silverstone for my Artisan 30 - fits like a glove.
by lucknow1856
Wed Jul 07, 2010 3:01 pm
Forum: HT Pedals
Topic: ht boost pedal?
Replies: 6
Views: 7511

Re: ht boost pedal?

No, but I've used one with the Artisan 30. You don't say what type of sound you're chasing but to me the main use for any 'boost' pedal is that with a decent valve (tube) amp if you push an otherwise clean channel hard and add the boost pedal you can get a big classic rock sound with as near to 'nat...
by lucknow1856
Wed Jul 07, 2010 12:58 pm
Forum: Artisan Series
Topic: Advice sought from Artisan 30 users on lead sounds
Replies: 2
Views: 7132

Re: Advice sought from Artisan 30 users on lead sounds

Thanx - I'll give that a try but using the HT Boost rather than buy a BB pedal.

I've now noticed there is a settings thread on the forum (don't think it was there when I posted) so I'll look in there from now on for ideas.

Thanks again.